[WIP] Camelot Expansion Pack - 0.2.5.2b


#326

Well i did the same thing to install Ultimatelib thing, i installed then ploped it into my mods folder, unless i didn’t unzip and i have the newest windows


#327

Camelot Update Tomorrow

Camelot will be updated tomorrow this will be a small update with some custom contracts and publishers.
Following this there will be a Grid update sometime next week :smile:


@jordanfmunro Did you follow the modding FAQ it explains how to install any mods :smile:


#328

Neither the Windows 8 Store or Linux have modding capability at the moment. It is unlikely that we will ever see modding support on the windows 8 store edition of the game but we are working on Linux.


#329

CAMELOT UPDATED - 0.2.5.0b

Just some small bug fixes.
New features include Custom Contracts and Custom Publishers.
UltimateLib 1.3.2 must be installed.
http://gdt-ultimatesuite.abesco.de/

Also some tweaks to Grid


#330

But, anyway it is money farm?


#331

@SirEverard I have a simple idea that I think would be very simple to you implement, add more phrases on game reviews, because i think that everyone here skip reviews because they just want to see the score and already saw the phrases, so i think that would be more interesting if the reviews have a lot of things to say about your game

Edit

And maybe add the option that reviews give you things like game reports. For example a review say “the sound of this game is terrible” you automatically gets a pop-up saying that you should invest more on sound on your next game for that topic/genre


#332

Good ideas I will look into these


#333

I had another simple idea that I don’t know how I didn’t wrote that on my last post, add decimals to game scores, so you can get like, a 7.5 that will increase sales more than a 7 but less than a 8


#334

That would make the overall review scores very weird. o.O


#335

Well if this will make the overall scores weird the solution is just put “.5” scores, like 7.5 or 2.5, i think that this way the scores will not be so weird


#336

Hi! Well… got a problem after updating to a newer mod version - after pressing the Find Publishing Deal button game crashed with the next error.

{"Message":"Uncaught TypeError: Cannot read property 'name' of null","URL":"file:///D:/Games/SteamLibrary/steamapps/common/Game%20Dev%20Tycoon/compressed/codeNw.js","Line":954}

Tried re-installing, re-enabling mod and UltimateLib, clearing the game cash - no use. Would appreciate any help on the issue. Thanks in advance! = )


#337

:clap: Congrats to 10k views :slight_smile:


#338

Confirmed. Looking into this.


#339

Pushed a new version that should have fixed this. Let me know if you still have trouble.
And make sure you are using the latest version of UltimateLib


#340

Great thanks for a quick response! Tried it few minutes ago and… still an error but a bit different one ( see the last number):

{"Error":{"Message":"Uncaught TypeError: Cannot read property 'name' of null","URL":"file:///D:/Games/SteamLibrary/steamapps/common/Game%20Dev%20Tycoon/compressed/codeNw.js","Line":964}

In case:

  1. Using the latest UL;
  2. List of other mods I have: InfoStatsMod by @alphabit, Khan’s Expansion Pack Mod by @DzjengisKhan, Better Error Handling by @Jari;
  3. Have cleaned the cache and re-enabled all the mods one by one once again.
  4. The only thing I haven’t done this time is restarting campaign. Used the recent save instead. Unfortunately can’t do it right now, will do tomorrow.

Hope this will help in fixing. Much appreciate your work! Great mod, keep on ^^


[REL] Expansion Pack for Game Dev Tycoon
#341

Version 0.2.5.2b pushed.

With a little help from @alphabit this should fix the issue :slight_smile:


[REL] Expansion Pack for Game Dev Tycoon
#342

Awesome! Now it works, even with the old save-file. = ) Many thanks again for a quick fix ^^


#343

The Mod is bugged you unlock everything as soon as you unlock game engine I’m using Camelot With the Gamedevtycoon Upgrades mod.

As you can see on this page I’m unlocking everything at once when I should’t really is lame I loved the mod but I cant use it so great


#344

In the page, all the things you unlock are from my mod, I dunno why this happens, because I added a criteria to ALL the engine parts, maybe this is bug in UME, I will talk to @alphabit


#345

I have a problem with this mod. The problem is that I’m not able to scroll down in the console menu please help