[WIP] Website mod : create your own website!


#51

I upload an update for the mod. If a modder wants correct the bug…


#52

@solal2003

Well other than your code being riddled with syntax errors. it doesn’t actually do anything other than add an event that doesn’t work.

The researches you have added are again full of syntax errors and the method in which you attempted to add them is completely incorrect.

However. You may wish to consider looking into the UltimateSuite project myself and @alphabit are working on.

The UltimateLibrary includes methods for adding special and lab researches (considering the GDT-API only contains methods for engine researches)
This will also be encompassed in our UltimateModEditor aimed at beginner modders and when there is a public release you will be able to use it to recreate this mod.


#53

Thank you for answering. I suppose I have to use push(), like in the mod api, right? That’s weird, because Greenheart Games doesn’t use push() in the game code


#54

new version updated, using now UltimateLib!


#55

What is going on?


#56

Have you got UltimateLib?


#57

Yes I Do 1.1.0


#58

I have the same error


#59

I added little changes to it .json file and don’t got error more(I delete its ",
“UltimateLib” : “1.1.x”
},
“license” : “GNU GPL v3”,
“copyright” : "Website mod
Copyright © 2014 Solal solal.rastier@me.com

This file is part of Website mod.

Website mod is free software: you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation, either version 3 of the License, or
(at your option) any later version.

Website mod is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
GNU General Public License for more details.

You should have received a copy of the GNU General Public License
along with Website mod.  If not, see <http://www.gnu.org/licenses/>."

}" from the .json file)


#61

This modification is prohibited by license used (GNU GPL v3). You have removed the copyright notice, which is an Copyright Infringement. Delete the link.


#62

This json file you have released is also incorrectly written and will not work with UltimateLib.


#63

Please upload your code to GitHub and I will fix your code and send a pull request.


#64

I don’t like use systems like git, svn, mercurial… because it’s very complicated. You can write on this topic if you have a solution.


#65

GitHub is very simple you can do it all on the website.
You just need to create an account. Start a repo and upload your code.
There is a lot wrong with your code.


#66

But… How upload files? @SirEverard


#67

Sorry but srsly i get error. With UltimateLib


#68

So, you have same error with your mod?


#69

@solal2003 Well, Fix the Code on Github or something.

or @Wayss can upload the modified .json file that has he apparently stated that he he fixed it somehow.

Due its subject this mod has NOT COMPLETED. Due it’s has a lot of Errors.

It should remain @Charlie W.I.P - Not Release.


#70

Are you actually serious
-_-


#71

@solal2003 http://www.youtube.com/watch?v=u12zHGRfiKU