[WIP] Camelot Expansion Pack - 0.2.5.2b


#255

I really like this mod, can you say on what you’re working on for the next version?


#256

@Haxor Could be part of a bug with Grid. Either way the debugging research would not have caused this error.

@Poldemol Thanks :slight_smile: Currently I’m taking it slow. Working on expanding the UltimateLib while @alphabit works on the UltimateModEditor. Once we have release a big push with UL I will probably look to improving Grid and adding some smaller features I’ve listed.
More Grid related events, possibley some other interesting events that.
Conventions - Will be adding more options to choose from rather than booths.
Game Shelving [Postponing game releases] - Will be looking into this soon, may or may not add this in soon.
and I know a lot of people voted for Company Logos so I will be designing a system to implement them also.

They are probably the next things you can look forward to during the next month. :slight_smile:


#257

Good job on the mod! :slight_smile:


#258

Eh hehehe…

I abused the Grid thing since I noticed I get a ton of money whenever I put a ton into the grid…
So I don’t remember the number but I was in the Trillions.


#259

Lol… I’m already in the QD so it shouldn’t be a problem with that. :stuck_out_tongue:


#260

@kristof1104 Thanks :slight_smile: means a lot.

@MrRain Heh, yeah. I have yet to work fully on the algorithm. To stop this spiraling out of control - when that number gets to big the game will just give up and go home calculating anything - I will be introducing more limiting factors into the next update.
Which will make your choices with Grid (although limited atm) somewhat dependent on the amount of fans you have and the new Company Reputation modifier being introduced into the UltimateLib.
But yes, development will continue until I run out of ideas. :slight_smile:


#261

haha alright… Well then, I guess I’m gonna have to delete the save and start over eh?


#262

Well if you can load up the save. Stop Grid spending and perhaps @kristof1104 could introduce a “minus” money option in cheatmod for debugging :stuck_out_tongue: Would be very helpful. and then you can reduce you money a little and continue gameplay.


#263

Hahaha,

I love it when a plan comes together.


#264

Haha I’ll add a field where debuggers can set their money :slight_smile: nice idea actually!


#265

I researched AI Debugging 2 times and i can research it again? Okay


#266

Thanks for reporting this. Will be patched in the next update.


#267

don’t work, advanced option don’t appears, and yes i have ultimatelib


#268

Sounds like you haven’t installed the mods correctly. Make sure UltimateLib and Camelot are blue on your mods list.


#269

fixed now, just steam mocked with my game files, and i can’t create character now, but after restart and loading clear save game let’s me do it. Why?


#270

Turn off steam cloud.

Sometimes will muck up your game if you are using mods.
Rightclick GDT and hit properties to bring up the window.


#271

kind of worked, previous errors gone, but now it spams with those errors: “cannot read amount of null” (or something like that) Cannot read price point (again something like that) and tons of uncaught errors. braking game.


#272

Did u also try to “reset” the local storage where the local save states are stored?

You find it at: c:\users\YOUR_USERNAME\AppData\Local\Game Dev Tycoon - Steam

http://puu.sh/6wvN2.png

You can simply rename “Local Storage” to whatever and see if the game works with the mods after that. Be aware, that you’ll lose all save states.

By renaming it back, you have your old save states back.

As @SirEverard already mentioned, it’s a good idea to have Steam Cloud disabled when using mods, as it will load/save states from the steam cloud.


#273

not helped errors that appear are: on startup “property not set for object pointcost” when i click start "uncaught error object 3.666666666666665 ha no… (rest isn’t visible) and game breaks down.


#274

What other modules are u using? Only Camelot + UltimateLib?