[TUT] Installing mods on the most recent version


#1

List of all mods:
http://forum.greenheartgames.com/t/official-mod-list/

Installing mods:

Go to your Steam folder then add this location onto your address bar:
\SteamApps\common\Game Dev Tycoon\mods

Next just select the .zip archive that contains the mod and extract the folder onto the .mods folder.
Then just boot the game up, select the mods in the mods menu and play the heck out of the game! :smiley:
Discuss any mod-related issues or glitches in the respective thread, not here.
If you can’t manage to install it, (for example the mod doesn’t appear in the mod selection) reply here, please.

Default directory of the game (Steam):
C:\Program Files\Steam\SteamApps\common\Game Dev Tycoon


[Solved] A little question for admins/mods
Version 1.4.5 for Windows and Mac is live
#2

What do you do when you want to install a third mod, after you already have 2 mods installed.


#3

You repeat step 6-8


#4

@glampkoo I got 1 error.

1st error: Uncaught Syntax Error: Unexpected Token {

Code:

var ModConfig = {};
(function () {

	ModConfig.enabledMods = [
	{ script: 'gdt-modAPI/modAPI.js'},
	{ script: 'ExpansionPack/ExpansionPack.js'},
	{ script: 'Game-Dev-Tycoon-Mod/game-dev-tycoon-mod.js' }
	];
})();

I am trying to test out my mod to see if it works or not.


#5

I think that should work. Try putting the Game-Dev-Tycoon-Mod out of your folder and test it again. I know gdt-modAPI works fine and eiter does ExpansionPack, I don’t know about Game-Dev-Tycoon-Mod. Tell me when you still get the error after putting the Game-Dev-Tycoon-Mod folder out of your mods folder.


#7

After learning about the new modding support I logged into Steam, registered my key, set up to download Beta versions, and ran into a wall. Specifically a key file, modConfig.js, is not present. So, I went and uninstalled the game, re-downloaded it thinking it must have been an error. But no, still not present. Double checked to make sure hidden files were showing, still nothing.

I know I have a mod support beta as it has the option to enable mods when I run the game (v1.4.5), even shows the released API. But there is no modConfig.js to be found anywhere, and dropping in an additional mod only creates error messages about how it’s not in the modConfig.js.

Is there somewhere I can get the modConfig.js so I can install it by hand, or am I just out of luck here?


#8

this is outdated. there is no editing of modConfig necessary anymore. just copy/paste the mods in the ./mod folder and they should show up in the Mods section under the main menu.

http://forum.greenheartgames.com/t/announcement-first-beta-version-with-modding-support-is-live/8612/45?u=patrickklug


#9

So I think this post is now useless? What do you think?


#10

Where is this mods folder for us linux users?


#11

the mod support is currently only in beta on Steam for the windows platform.


#12

How do i get t the ./mod folder? I have v 1.4.4 and Steam says i dont n eed an update


#13

Because you need to have the 1.4.5 beta version.
Go to your library and right click Game Dev Tycoon.
Then go to the last tab that is Betas and then select the box that has the translations. It should have a versions called "Beta - beta"
Select that and now you can load the mods into the game.


#14

B ut how do i put mods into my game?


#15

Go to your Steam folder then add this location onto your address bar:
\SteamApps\common\Game Dev Tycoon\mods

Next just select the .zip archive that contains the mod and dump the folder onto the .mods folder.
Then just boot the game up!


#16

Thank you SO much man! I am so excited for the Ciber mod!


#17

Always glad to help someone!


#18

Wait

Now its not letting me enable it?


#19

Can you please give me some more information like a screenshot? It would help a lot!


#20

Ok.

As you see here the folder is in the mods, but i cannot enable it in the MODS button.


#21

I think you have to read this sentence:
Next just open the .zip archive that contains the mod and extract the folder onto the .mods folder.