[WIP][TOOL]UltimateModMaker [New 1.0]


Windows 10.


I have also windows 10 and by that also .netframework 4.6, i have the programm “runs as Administrator”, nothing…
my cursor becoms to a loading circle and than nothing.
I have used the switly Luncher and the UMM!


well that’s just 1999


Ooh sorry I meant 4.6!


What CPU do you have? 32 or 64?

Generally the application is for any cpu but maybe I can build it for your cpu and give it to you for testing to see if that fixes it all.


x64. Maybe the program is only for x86?


I use Visual Studio 2015, and there are options for (X64, X86, and Any CPU) I use Any CPU
But that may be the problem possibly.


Yeah maybe. Put a link up for both x86 and x64.


I will give you a link to a 64 bit version in a bit. But I will not add it to my website until it actually makes sense too.


Try using this: 64 Bit Download

So this is actually an update ahead of what is currently released to everyone else.


Still not working :frowning:.


:stuck_out_tongue: I know, I know

@SnowyOwl nah, Any CPU works with any CPU, don’t believe that will work.
EDIT: oh nvm, it didn’t work


So I need people to test this.

I’ve been asking for help giving details of whats going wrong. I’ve never really used such a dumb code but I added all the libraries even if they should already be on your computer or embedded.

Download(All CPUS)


Still doesn’t work. looked at windows event viewer, but not sure how relevant these logs will be


This is helping tremendously. More then you know…

So for at least the UMM I think I may have found the problem. Could be the same for the Swiftly Launcher and so on so please give me a little shouldn’t take longer then a few minutes actually.


So turns out I wasn’t checking to make sure that a certain folder / directory existed before I tried using files in those directories.

So now its all fixed.

If you download the swiftly launcher even though it wouldn’t open the updater is the file you download which then downloads the launcher. The updater had no bugs so it should automatically updated the launcher to work from there. Then you can download the UMM from there. OR you can download the UMM from the website.

Notify me if this still doesn’t fix anything!


It works! However it is very slow. Could you add an option for no background image and maybe try to find a way to speed it up? Also when will events be added? And for some reason I can’t modify consoles.


Modifying consoles has been disabled… Sadly. Plus I found some bugs with making consoles so I’ll have to fix that later.

And I am currently trying to find out how to make this faster


its work it! YES!
the “all CPUS” download work it by me!
but mods with Platforms don’t working. I havejust GDT API!
mods with only Topics are working!
it come a red windows with this:"

Syntax Error; unknow Token

loaded mods:
more_platforms by speedy_242"


Thank you for the report. I have already found this bug. And when I get the time I will fix this bug.