Unable to purchase iOS version of Game Dev Tycoon


#1

I am trying to buy game but it will not let me. I get the following error “Unable to purchase ‘Game Dev Tycoon’ is not compatible with this iPad.”

However, my iPad does meet the min specs. I have an iPad Mini 2 with iOS version 9.3.5. So the game should work but it doesn’t.

Any ideas?


#2

Sorry to hear that it’s not working for you. iPad Mini 2 is definitely supported, and also listed on the AppStore itself as a supported device. I suggest to logout/login your Apple ID first, then try again. If that does not work, I think you need to contact Apple directly.


#3

Thank you for the reply. I have tried that, still doesn’t let me purchase. Might want to check with Apple to ensure they have the settings correct to allow the download to occur. The text on comparability is correct but perhaps a background setting is set incorrect. Thanks.


#4

@Armor9
I bought it for iPad mini 2 as well. It runs very well. I am on iOS 11