[REL] [Tools] UltimateSuite - UltimateLib [1.3.4]

It’s easy >_< (Well maybe except events)


It’s not D: How much time did it take to learn modding Game Dev?

Not long, if you read the api, you could probably learn the basics in a few weeks

You just copy examples and change some things?

Ugh. I may need help in the start though

DM me, ill help ya

DM? you mean PM(Private Message?)

Yeah, that, i use twitter a lot, so i’m used to calling it it a DM


mh, why not just make a UME that uses the gdt-modapi instead of UltimateLib

1 Like

For some reason whenever I get to the final stage, I get this error : Cannot set property ‘complete’ of undefined (file:///E:/SteamLibrary/steamapps/common/Game%20Dev%20Tycoon/mods/UltimateLib/UltimateLib.js:1852)
I’ve tried just about everything and i can’t get it to work. Also I tried the disable mods one by one trick but it does not work and I still get the error. I’m not sure what to do.

Known bug with UltimateLib. Try playing without it or avoiding the R&D lab.
or use an older version

Do you know where you can get an older version? I have the same problem with the R&D lab but I would want to use it if possible so I would want to try to use an older version of UltimateLib first.

ultimatelib on github. Press changelog, choose a version and download it.

I can’t seem to find the changelog.

Just as I unlocked the R&D lab, I encountered this error:

Error Uncaught error. Please report this to support@greenheartgames.com: Uncaught TypeError: Cannot set property ‘complete’ of undefined (file:///C:/Program%20Files%20(x86)/Steam/steamapps/common/Game%20Dev%20Tycoon/mods/UltimateLib/UltimateLib.js:1852) Please restart the game.

Enabled Mods: [“gdt-modAPI”,“UltimateLib”,“TCM”,“RCM”,“PCM_UnKnoWn”,“PCM_Other”,“CCM”,“ACM”,“CheatMod-kristof1104”]

I would like to know exactly what is going on here, if it’s something I did or if it’s a bug, or perhaps some things are incompatible with eachother. It says the error is in the UltimateLib.js file so I assumed that it would be here that I post this, sorry if I was incorrect.

Please help me correct this error if possible, I would not like to have to restart my game, it took several days to get to this point… Okay, that’s a lie, it took about 4 or so hours. Either way, I would like to keep my progress.

Thank you all in advance for your assistance,

That’s a known issue

Ah, I see. I neglected to read the rest of the topic here. Thank you for pointing that out. Well, time to go mess with UME until I accidentally make some form of mod, hopefully one that doesn’t require the broken version of UL, since my actual game is apparently broken due to UL.

1 Like

@KiritoHalo (kek, dat name)
Get an older version of UltimateLib

I have created a patched version of the current UL which addresses the research lab issue.
Currently, it can be found here:

We will update the UltimateLib properly after the Steam Workshop (next update) of GDT.
Have fun!


Thanks very much!