[QUE] Error: could not load mod (something about API?)

You’ll need to bear with me as I’m not too familar with modding and I might be missing something obvious.

I’ve got a number of mods installed - CheatMod, Camelot, InfoStats, UltimateLib, GDT Expansion Pack and the API thing. Only CheatMod seems to be working, though.

When the game first boots up, I get this error window. It pops up eight times before I can finally click it away:

Could not load mod one of the scripts C:]Program
Files\Steam\steamappa\common\Game Dev

The rest of the text in the error window appears to be cut off. I guess that means there’s an error (or a number of errors) with my API? I’m not sure. All of my installed mods show up in the mod list within GDT and I can switch them on or off, but aside from CheatMod none of them actually appear in-game.

1 Like

post a snapshot of your mods folder please

Sure! Thanks for the quick reply.


Inside the mods folder

Oh my god! I’m such a spaz, I probably need to get some sleep. :S


You have the api master folder, inside that folder is another folder, that is what the issue is (Don’t worry it’s a common mistake) :stuck_out_tongue: (Same thing goes for Expansion Pack)

1 Like

I see! So the contents of the api folder inside the master folder should be moved to the parent folder? Or should they be moved to their own subfolder inside the mods folder? Or does it not matter?

(Finally, this will be taken care of! Thanks again for being so quick to respond, wasn’t expecting to hear back from someone so quickly!)

1 Like

Yes, the contents of the folder should be inside the parent folder

Wonderful, thanks for the help!

1 Like

Okay, so I’ve moved the files into their parent folders (so the files that were in the api subfolder are now in the api master folder inside the mods folder), but I’m still getting the same error messages and all of the mods aren’t working. Is there something else I might have missed?

The sub folder should just have been moved into the parent folder not inside of the api master folder

Sure thing. Only I’ve now moved the api folder so it’s directly inside the mods folder, and I’m still having the same problem… next thing to try?

Send me snapshot of mods folder (Like the 2nd one you posted) and the in game mods list

Sure! Here’s the updated mods folder:


Here’s my mods list in GDT (two parts):


First delete the master folder, second don’t move the contents into a different folder you just need to move the folder inside the api master folder

Wait, I need to delete the master folder but then also move the folder into the master folder? I don’t understand.

Are you trying to say thing things that are in \mods\api (in that last picture I posted) should actually be in \mods\gdt-modAPI-master? If so, well, that’s what I had earlier and I still got this problem.

-_- no the folder inside the parent folder needs to be moved into the mods folder, you moved the contents into a different folder

you are using an outdated version of Game Dev Tcoon. I’d recommend you delete the entire mod folder, then make sure that you are not using the beta version of GDT in steam and then verify the local game files.

You don’t need to download the gdt-modAPI as it is already included with the game.


Sorry that I keep asking questions, I really don’t seem to be grasping this.

I checked on Steam and I’m not using any beta version. I uninstalled the game, deleted my mods folder and then restored the game from Steam (my save files appear to be intact). I reinstalled the mods. I’m still getting the same error message. None of the mods are working (I can switch them on, but I then start a new game and none of them show up), except for CheatMod, which seems to be on regardless of whether I have the option selected or not.

Anyway, I’ll post images of the Steam settings I’ve got for the game, the list of mods I have installed (all currently switched on), the GDT and mods folders as they currently are, and the folders for each individual mod I’ve got installed. Perhaps someone can decipher what I’m doing wrong and spell it out for me? I might need someone else to post screenshots of what their folders look like so I know what I should be seeing in my folders. Otherwise, pretend you’re writing “GDT for Dummies” because I’m clearly not understanding something.

Anyway, here goes…


Thanks again for taking the time to help someone who isn’t very literate when it comes to Steam or GDT!

Just to make sure, is there a “modAPI.js” file inside the “gdt-modAPI” folder (and no folders except “api”, “examples”, and “helpers”)?