Mod Loading Error


#42

Both of these.


#43

Yes, I am. Thank you for that information.


#44

Sorry for bumping.

Byt in my eyes, it looks like you dont have the Mod API installed… ?


#45

Really? I don’t have it in my folder. I guess one or more GDT updates might have broken it.


#46

Which version of the game are you running and where did you purchase it from?


#47

Latest version, bought from Steam Store.


#48

I didn’t take the time to read through this whole thing but what is your problem?


#50

Could you provide a screenshot of your GDT installation folder?


#51

Here it is.


#52

I’m assuming you’re placing the mods in mods_ws.

If so, then place them in mods, not mods_ws. mod_ws is for mods downloaded from the Steam Workshop


#53

Most of, if not all, come from the Steam Workshop. Idk what mod is giving the error.


#54

Could you give a screenshot of the error?


#55

Seems this worked: @jomismo I never had that problem until last night when I reinstall everything. I notice that if you try to use this mod without having played at least once without mods it will not work. It need at least one clean save.

My guess is that “TypeError: Object # has no method ‘getDataStore’” means that GDT uses MySQL, SQLite, or some similar DB and it need a save to extract the money value, so if you don’t have a clean save it will not found the right value, or position, or something like that.

So, to fix it, just disable all mods, start a new game, make a game, earn some money, save game, enable all mods, exit GDT, start your new game with the mods you want enabled… It worked for me!

Found @ https://steamcommunity.com/sharedfiles/filedetails/comments/393236776

Also, on an off-topic note, how long is optimal to wait between game and sequel to get great ratings?