Error Message with mods

Hello guys,3 days ago i bought this fantastic game but i had some problems with mods,i tried to download and activated some mods (AchiavementAndConsoles,endgame renewed,Game expansions,Game Ultra Tycoon,infostatsmod,portable wars,savebackup,ultimatelib) but when i start a new game i have an errore message:

"Errore Errore non riconosciuto. Si prega di segnalarlo a Uncaught TypeError: Object [object Object] has no method ‘canDevelopLargeGame’ (file:///C:/Program%20Files%20(x86)/Steam/steamapps/common/Game%20Dev%20Tycoon/mods/GameExpansions/main/code.js:22) Si prega di riavviare il gioco.

Enabled Mods: [“gdt-modAPI”,“InfoStatsMod-AbescoUG”,“savebackup”,“UltimateLib”,“963d50e3-e45c-4867-bdab-88b57441ff1b”,“c9f233bc-31e1-41f1-ab58-0f2206193530”,“9d1a6606-583e-45ec-a172-711e9c259e82”,“1f4a2b2d-c640-414c-a097-9a5e7c446f8c”,“2055dff5-9c36-40e7-9c09-27f831”

If i disable all mods i can play without problem but,for example,if i active ModApi and UltimateLib mod i have the same error (i don’t use workshop’s mod).
Can i resolve this problem?How?Thank you.


Firstly you need to be aware that once you load mods into a save game, the game data is forever changed. Therefore unloading mods will cause even more errors. Therefore whenever a mod is removed a new game must be started.

With this information in mind I would suggest starting a new game.
To do this as soon as the game hits the ‘click to continue’ screen press the ‘escape’ key and select ‘new’ from the menu. Be sure to not have any mods activated if you want to maintain the integrity of your new game.

From here you can mods one by one starting with the modding api and then ultimate lib. From here choose which mods to add carefully.
Check the information thread for each mod. Are there many recent bug reports? If so do not add it.

Hope this information helps. You will probably find it helpful to check out our modding FAQ; Official Modding F.A.Q

Thank you for the answer,but i tried it many times,before the tentative to add mods i read the F.A.Q infact to activate the mods i selected it in the menu and then closed the game,but when i started a new game the same error appear,i tried to able only UltimateLib and API mods and i have the same problem.
Now i’m playing with workshop’s MOD and the error don’t appear.

So you found something that fixes it?

Ok well just for you to know mods can get broken or can sometimes not work with other mods and that can cause errors, also having to many mods I’ve figured out causes some problems. Things such as ultimatelib mods are not the best mods to get and use because it requires a mod that takes the code that the mod has written down into the actual mod. Basically what I’m saying is UltimateSuite does not create mods in the actual modding code. It writes it in its own code and then has another mod UltimateLib transform it. Which can cause problems.

So again things that can cause errors could be, too many mods, ultimatelib mods, mods that don’t work with each other.

Workshop mods have are updated easier and most of the time work better then mods you download and put into the folder manually.

Yes i partially resolved the problem,i’m using workshop’s mods and they work without error/problem,i activated 8 workshop’s mods (mods who i added manually were 9).

The main issue i had was appearence of the error box when i active only APIMod and UltimateLib.