Android Save Files Gone


I downloaded Game Dev Tycoon for Android today and played for a couple hours. When I came back to the game tonight, my saved games were gone, and the only potential load games are Y1 M1 W1.

It also appears that I can no longer start a new game.

You didn’t save…?

I’ll leave this for the Game Dev Tycoon mobile team to investigate. cc /@rangermann

Can you clarify what happens when you try starting a new game?

Are you logged into Google Play Games, and are you using cloud saves?

Regarding the issue when starting a new game - can you describe this in more detail what happens when you try to start a new game?

I was logged into Google Play Games, but it was apparently with an account different from what I used to buy the game in case that is relevant. I don’t recall setting up cloud saves, and don’t actually see an option to even do that. I’ve since tried changing the Google Play Games account that’s logged in with no success.

For starting a new game, pressing “Continue” just doesn’t do anything after I enter in my player and company name.

Cloud saves is enabled by default, I’m pretty sure you cannot disable it

Cloud saves are enabled by default, that’s correct - as long as you are logged into a Google Play Games account.

To me it sounds like your cloud and/or local save data is somehow corrupt. Have you tried to remove the game from the device and then re-install from the store?

I just reinstalled it and can start a new game now.

Great to hear, if you have any more questions I’d be available to answer them.

Ok, great to hear that - just let us know if you experience any other issues.

Hi, mine’s saving and loading was fine until my device automatically shut down while playing the game. Opened the game again after I opened the device(ofcourse) and the game prompted me telling that my local save files and cloud(?) save files are not synced and asked which to load. Chose local since I’ve been playing the game while not connected to the internet. And it loaded a Y1 save file.

Tried this

but gives a Y1 M1 W1 game

tried to load all slot but all gives a Y1 M1 W1 game

(assume, these are the slot numbers)
auto and 4 are (coincidentally?) identical(same topics and player avatar) same with 1 and 2. While 3 is another save file, 5 prompts to a new game.

Also, under /Android/data/com.greenheartgames.gdt/files/ there is no local_4.txt, local_slot_4.txt same with 5 and their L1, L2 thing. (if this helps)

I didn’t used the save function yet hoping to not mess up some files.
I just want to see if it’s a game bug or my device’s problem before reinstalling the game and avoid what’s needed to be avoided.

Thanks in advance!
(Sorry bad english :slight_smile: )

From your description this sounds like the device wasn’t able to save the game to the local save file (which could happen in cases when you don’t have enough space left on the device). Do you still get the question that asks whether you want to load the local save file or the one from the cloud? If yes, what does happen if you load the one from the cloud?

I still have enough space left on my device.

I tried opening the game while connected to the internet, no more prompt. Clicking load still shows the picture above but now, [auto] loads a Y10 M11 W4 game, [slot 1 and 3] loads Y1 M1 W1(not identical). [slot 2] loads what [auto] loads but different in-game date and not Y13 M3 W3, [slot 4 and 5] both prompts to a new game.

If you are connected to the Internet (and use Google Play Games, which means cloud saves are supported), the load dialog should display details from your cloud saves. If it it out of sync with your local saves (e.g. if you played offline in the meantime), then it should ask you to pick the correct save game for the given slot.

If there went something wrong when your save game was saved to the local disk, it may help to load the correct cloud game and then save it manually again (rather than waiting for the auto-save to kick in).

I’ll just clear the game’s data to restart it but one last question or 2 if you may, does choosing local save over cloud save will update the cloud save? or how can i update my cloud save manually? Thanks again!

Your cloud save game will be overwritten the next time you save the game (if you are connected to the Internet, of course).