[WIP] Expansion: InfoStatsMod - 0.4.2

Hey I was getting a GDT error at the start of the game, doesn’t break anything just annoying when it flashes at me in the bottom of the screen I added:

if (GameManager.company.gameLog.length < 1){ return; }

To the start of the m.weekProceeded function which seemed to fix it.

Thanks @SirEverard:smiley: I’ll check and fix this. I’m already working on the 0.3.0 version which also fixed quite some other annoyances and bugs.

Anyone else with the same problem?

1 Like

What about custom consoles (and computers)`s release details?

@Haxor: I have a console, custom consoles analysis section in planning (sort of an overview of all systems released so far with information about life time, income, profits, costs, released games, min/max market share, features for custom systems, sold units for custom systems). Is that what you’re talking about?

Yes, It is. Im waiting for it.

New screenshots available from the current development (0.3.0 - not released yet):

@SirEverard I have reworked the function causing the problem. The bug should be fixed now! Thanks for telling :smile:


Any idea when the update will release?

I would say very soon… I think within the next 48 hours, could be a couple of more, too. Just need to do some tests (I need to play a game from scratch now) and fix some annoyances and small things.

I’m considering to use an additional download server for providing quicker update cycles for development versions (in between the main releases)… let’s see with what I’ll come up the next days :wink:

Also, I think there are some incompatibilities with this mod and the Game Dev Expansion Pack mod. I can’t exactly remember what the error was but it happened as soon as I launched the game. Although, it also could be the modding api, who knows.

There are no known incompatibilities with the Expansion Pack, in fact I developed always with that mod and the cheatmod running at the same time :smile:

You have another kind of error when you start the game. @SirEverard already mentioned that kind of problem a couple of posts before. This has been fixed in the next release. Sorry for the inconvience.

Btw. I could need some testers for the next versions… if someone is interested I would be very happy :smile:

From now on, official and non official releases can be downloaded from GitHub Repository.
I’ll publish all stages of the mod development to the repo, while keeping main releases updated on NexusMods and GameDevMods.

Current available a non official 0.3.0 alpha release. More details are directly available on GitHub.


Hi @wimali, thanks for your requests and ideas. About consoles and computers (of the Expansion Pack) I’ll answered a couple of posts before I’m already planning a console, custom consoles analysis section (sort of an overview of all systems released so far with information about life time, income, profits, costs, released games, min/max market share, features for custom systems, sold units for custom systems). A handling and view of DLCs and MMO games is still an open area which is scheduled for the next development stage. What details are you talking about when you’re saying “a more detailed engine list”? Could you please specify?

Hey for some reason whenever I try to click on any of the games I’ve made to make the game detail window thing popup I get an error. This is what the error says:

Uncaught error: Please report this to
Uncaught TypeError: Object [object Object] has no method

Is there something I’m doing wrong? I am using version 0.2.0. I also have a few more mods running too. Those are the Cheat Mod by kristof1104 V0.2.3, Expansion mod V0.5.1, & more topics mod V1.5.1. Did I scre up during install or something or do I need to start a new game? Any help as how I can get this to work would be great.

1 Like

Got this error too.

@glampkoo Yeah I have tried multiple ways to fix it that have worked for other mods (Mainly just reinstalling or starting new game etc) and nothing has worked so far. I think it’s a bug.

What screen resolution are you using?

@alphabit Umm, well I use windowed mode and not fullscreen if that has anything to do with it. My maximum screen resolution is 1336x768 since I am using a crappy laptop.

It’s definitely a bug in the mod. Normally you should get a popup dialog displaying game details when using resolutions with a width lower than 1550. I’ve tested it on my current development version and I do receive the same error message.

I already fixed the bug and will release a new version within the next couple of hours, which should work then :slight_smile:

Thanks man! I really appreciate it! The whole reason I got this mod was for all that additional info that is displayed in the detail window! It triggered my interest in this mod so I can’t wait to see all the stuff this mod has to offer! :smiley:

I have uploaded a new development release (0.3.1) to GitHub. :smile:

See the first post of this thread for information.
More info at the GitHub Repository

Please report any errors here.