My game has this error and wont stop!


#1

So I modded my game on steam and it worked the first day but the next day i got a bug and i uninstalled all my mods and deleted and re installed the game 5 times but the bug (or something like a uncought error) keeps coming back. It looks like this:


Error Could not initialize loaded game: TypeError: Cannot read property ‘id’ of null If the issue persists please report this error to support@greenheartgames.com

Enabled Mods:

No mods activated.
Game Version: 1.5.23

Platform: Windows

Distribution: Steam


So yeah please help.


#2

It was probably corrupted when using the mods. If it’s already been corrupted, removing mods will do nothing. Did you use any mods that require UltimateLib?


#3

Yes and i did use ultimate lib. how do i uncorrupt it.


#4

Just letting you know that UltimateLib is way out-of-date. I’ve never had a problem with my GDT saves being corrupted, so I’m not the guy to ask.


#5

ok


#6

thx for letting me know and i figured out how to uncorupt the file. :slight_smile:


#7

I’m afraid to tell you that–at least in my experience–once something is corrupted there is usually no way around it. For future reference, check this out. :smile:


#8

Cool, congratz! :smile:


#9

do you happen to know a mod that is like the same as ultimate lib so i can use my mods again?


#10

Currently, no. Though, I do believe someone is developing one at the moment.


#11

Yep.
The mods can just die the hell out of your game.
Reinstalling it should work.

Yes I know it’s solved
dammet


#12

When that new thing will be developed can you let me know?


#13

Sure thing. :smile: