Game Dev Tycoon wont run on AMD


#1

I have 2 laptops, one Intel, the other AMD Radeon A6. Game Dev Tycoon runs fine on my intel but just shows a black screen on AMD. I have tried everything Google said. I have the game on Steam.


#2

I have the same issue and I have an Intel Computer except I bought it from the greenheart website, GDT probably needs an update for Windows 10 or something because everything except for the graphics is working for me. (I can hear the music, click buttons and do stuff but my character is figuratively blind.) :thinking: :sleepy: :cold_sweat: :scream:


#3

Do you have the correct drivers for the AMD based laptop? Does it give any errors?


#4

Yes I do. No errors.


#5

Hi there,

Sorry for the trouble! Make sure your graphics card drivers are fully updated. If you’re using an AMD card, the solution might lie in disabling some AMD processes in your task manager:

AMD Gaming Evolved
Raptr
Plays.TV

The game may fail to launch or crash if the AMD Gaming Evolved overlay is enabled, which is why the necessary workaround would be to disable one (or more) of the above-listed processes.
Give that a try and let me know if it helps!


#6

Yeah, tried that. Didn’t work/


#7

I’ve found out how to fix it in another forum…
Go to the Catalyst Control Centre and in graphics turn power saving mode on instead of enhanced graphics or other option.
If that doesn’t fix it look at @FrancescaLeon’s post above (or below).


#8

Where do you download the Control Centre. The only reason I haven’t tried that is because I cant find where to download it.


#9

It should already be there. just right click on the desktop background and it should be called something like control centre or catalyst control with a blue and red symbol next to it. I hope that fixes the game for you! :smiley:


#10

I have something called AMD Radeon Settings but there’s nothing there to change the game power mode.