Can't go to translation website


#1

Hi, my name is Magnus and i come from Norway, i tried to register to the translation page but when i clicked the link in the email, i could not get to the website, i tried to click the link i found on google again but i did not get access.

I have translated before but the website was taken down of an unknown reason.
I translated in Norwegian Bokmål.


#2

Hey @GamesIsBest

Thank you for taking the time to contact us. I am very sorry about these troubles. Our translation site suffered an epic fail during update and that side of things went a bit awry. We have brought up a new site in the meantime while we see what can be salvaged from the old site.
We currently have quite a few people registered on the new site so unless there is a new issue this may be a localised or browser issue. Have you tried using a different browser and checking that a pop up blocker is not blocking the link from opening? Also please try copy pasting the link into your browser and see if that helps.
Again I am very sorry for all this fuss.


#3

edit: the same happen when i used internet explorer, its like the browsers get useless.

Thanks, i used google chrome but i did go to internet explorer and it works, but please fix the website for chrome.


#4

Hey,

Very sorry about that. Are you familiar with Github? If you are you may find using that much easier: